1&1 : lenteur et erreur 500

Vous avez dû remarquer, depuis le passage à WordPress 2.7.1, que mon blog était plutôt lent et affichait de nombeuses « Erreurs 500 ».

La partie d’administration du blog était particulièrement pénible. Christine, qui devait pester autant que moi 😉 lors de l’écriture d’articles, avait déjà publié un article en fin de semaine dernière Petits moyens pour contenir et optimiser la base de données d’un blog sous WP. Bien que j’aie suivi tous ses conseils 😉 la situation ne s’était pas vraiment améliorée. J’ai même désinstallé StatPress Reloaded ce week-end sans changement notable !

Christine m’a envoyé hier soir ce message :

Tu as probablement lu ceci, mais au cas où…
https://wordpress-tuto.fr/error-500-internal-server-error-675

Et bien non, je n’avais pas lu cet article… je m’apprêtais à téléphoner à 1&1 pour voir d’où pouvait venir le problème.

L’article de WordPress tuto, mentionné par Christine, propose de rajouter deux lignes dans le fichier .htacess (1) :

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Lors du passage de 1&1 à PHP 5 il y a environ un an, j’avais déjà modifié mon fichier .htaccess en y ajoutant la première ligne. Je viens de rajouter la deuxième, il semble effectivement que le blog s’affiche un peu plus rapidement, y compris dans sa partie d’administration.

A suivre donc !


Ecrit par Lise - Site

  1. Le fichier .htaccess se trouve à la racine de son espace web. Il faut choisir d’afficher les fichiers cachés pour y accéder []

8 commentaires pour “1&1 : lenteur et erreur 500

  1. Bonsoir Lise,

    Nous en avions parlé ensemble du cas 1And1 et de ces erreurs fréquentes à chaque nouvel article. Pour ma part, j’ai effectivement modifié le fichier htacess en rajoutant ces lignes de code et tout fonctionne depuis. Ce qui est regrettable c’est que l’hébergeur ne l’indique pas lui-même. Il serait assez simple de le proposer sur un forum complémentaire : à moins qu’ils attendent que nous les appelions sur un numéro surtaxé ?

    Bien à toi,

    Laurent

  2. Visiblement, cette manipulation n’est pas suffisante, j’ai encore des erreurs 500 et ça rame à certaines heures !

  3. Concernant le ralentissement, il m’arrive aussi d’avoir ce souci mais à l’évidence cela vient du serveur 1and1. Par contre, je suis plus étonné que l’erreur persiste.

    Voici le code de mon htaccess si cela peut te venir en aide, même si je suppose que tu dois avoir le même :

    # BEGIN WordPress
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    # END WordPress

  4. Ah non, je n’ai pas tout ça dans mon .htaccess.
    Si mon blog est aux abonnés absents dans les minutes qui suivent, c’est que ça aura tout planté 😉

  5. Comme je ne parle pas .htaccess couramment 😉
    pourquoi les deux lignes
    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    sont-elles répétées au début et à la fin ?

  6. Bonsoir Lise,

    On en avait tellement assez des problèmes que l’on a un peu forcé sur le code. Normalement, cela devrait marcher sans cette répétition.

    Par ailleurs, il y a un point très important que nous n’avions pas évoqué c’est qu’au moment où tu envoies le fichier, tu dois passer en chmod 444 afin que WordPress ne le modifie pas, ce qu’il a l’habitude de faire.

    Bon courage et n’hésite pas à me tenir au courant des suites.

    Bien à toi,

    Laurent

  7. Bonjour,

    Il y a toujours le problème,il faut réactualiser 3 ou 4 fois pour avoir la page.
    C’est l’hébergeur qui ne supporte pas la dernière version de wordpress?

    • Cela dépend des heures, parfois, l’affichage est très rapide, et parfois très long. Visiblement 1&1 supporte mal la nouvelle version de WP.
      J’ai adressé à 1&1un mail par jour la semaine dernière, sans aucune réponse en retour. J’ai repris le boulot sur les chapeaux de roue 😉 j’essaierai de téléphoner, mais je manque de temps…
      Je ne sais pas si les lenteurs sont dues aux serveurx mutualisés de 1&1 en général, ou plus particulièrement à celui sur lequel mon domaine est hébergé.

Les commentaires sont clos.